flexiCAD Rhino Forum deutsch

Autor Thema: Rhino 6, rendern- UV mapping  (Gelesen 1894 mal)

CAD-fm

  • Anwender
  • **
  • Beiträge: 19
Rhino 6, rendern- UV mapping
« am: 25 Aug 2018, 21:12 »
Hallo,
Ich habe ein Modell mit dazugehörigen UV maps  in Rhino 5 erstellt. In der gerenderten Ansicht in Rhino 6 sieht alles gut aus, auch der Druck des Ansichtfensters stellt das UV-mapping richtig dar. Beim Rendern in R6 allerdings, werden die Bilddateien falsch auf die Objekte angewendet. Wenn ich die Objekte in R6 mit dem UV-Editor "entfalte" ist ebenfalls alles richtig dargestellt. Was ist da los?

Grüße,
Frank

Michael Meyer

  • Administrator
  • Experte
  • *****
  • Beiträge: 2670
Re: Rhino 6, rendern- UV mapping
« Antwort #1 am: 25 Aug 2018, 21:32 »
Hallo Frank,

hast Du die neueste Version Rhino 6.7 installiert (siehe Hilfe/Info...)?

Kannst Du das Modell schicken?

Danke

Michael

CAD-fm

  • Anwender
  • **
  • Beiträge: 19
Re: Rhino 6, rendern- UV mapping
« Antwort #2 am: 25 Aug 2018, 21:49 »
Habe sogar SR8!
Das Modell würde ich ungern hier öffentlich machen. Gibt es eine andere Möglichkeit?

Michael Meyer

  • Administrator
  • Experte
  • *****
  • Beiträge: 2670
Re: Rhino 6, rendern- UV mapping
« Antwort #3 am: 25 Aug 2018, 22:22 »
Hallo Frank,

klar, schicke es an mich unter Michael.Meyer@flexiCAD.com. Ich schau mir das dann an, bzw, bespreche das mit dem Hersteller McNeel.

Danke

Michael

CAD-fm

  • Anwender
  • **
  • Beiträge: 19
Re: Rhino 6, rendern- UV mapping
« Antwort #4 am: 26 Aug 2018, 13:23 »
Ist eben raus... :)

Michael Meyer

  • Administrator
  • Experte
  • *****
  • Beiträge: 2670
Re: Rhino 6, rendern- UV mapping
« Antwort #5 am: 26 Aug 2018, 15:59 »
Hallo Frank,

Danke für die Datei, ich sehe das gleiche Problem hier in Rhino 6.7. Ich habe hier einen Fehlerbericht geschrieben und die Datei an den Hersteller McNeel geschickt:
https://discourse.mcneel.com/t/rhino-6-uv-texture-mapping-in-rhino-renders-falsely/69515

Mal abwarten, was McNeel sagt.

Dir noch einen schönen Sonntag,

Michael

Michael Meyer

  • Administrator
  • Experte
  • *****
  • Beiträge: 2670
Re: Rhino 6, rendern- UV mapping
« Antwort #6 am: 27 Aug 2018, 20:33 »
Hallo Frank,

der Rhino Render hat einen Fehler. Danke für den Hinweis, hier zu meiner Entlastung der Bug-Report:
https://mcneel.myjetbrains.com/youtrack/issue/RH-48040 1

Wann Andy den Fehler behebt kann man leider noch nicht sagen.

Alternativ kannst Du den Rhino-Render-Next (Cycles) ausprobieren. Damit sollte es gut aussehen. Den lädt man mit dem Befehl: _TestPackageManager

Gruß

Michael

CAD-fm

  • Anwender
  • **
  • Beiträge: 19
Re: Rhino 6, rendern- UV mapping
« Antwort #7 am: 28 Aug 2018, 21:17 »
OK, werde ich mal probieren.
Danke für deine Mühe!

CAD-fm

  • Anwender
  • **
  • Beiträge: 19
Re: Rhino 6, rendern- UV mapping
« Antwort #8 am: 28 Aug 2018, 21:56 »
 :o so, habe ich installiert, kann ihn aber nicht aktivieren. Nach dem auswählen schaltet die Auswahl auf "Rhino Renderer" zurück. Habe auch schon mit "_SetCurrentRenderPlugin" versucht umzuschalten - ohne Erfolg. Ich denke, ich warte noch ein wenig. Ansichtsfenster drucken sieht auch ganz nett aus...

Michael Meyer

  • Administrator
  • Experte
  • *****
  • Beiträge: 2670
Re: Rhino 6, rendern- UV mapping
« Antwort #9 am: 28 Aug 2018, 22:02 »
Hallo Frank,

versuch mal den aktuellen Renderer über das Menü Rendern/Aktueller Renderer/Rhino Render Next zu wechseln.

Andy schlägt auch vor die Texture in das Modell mit dem Befehl _Bake zu backen, um das Darstellungsproblem zu umgehen.

Danke

Michael

CAD-fm

  • Anwender
  • **
  • Beiträge: 19
Re: Rhino 6, rendern- UV mapping
« Antwort #10 am: 28 Aug 2018, 22:25 »
Über das Render-Menü hat´s funktioniert. Rendert jetzt fehlerfrei!